Click to view all our sponsors
Results 1 to 8 of 8

Thread: Engine will not run without choke (Subaru E10)

  1. #1
    Join Date
    May 2011
    Posts
    1
    Rep Power
    0

    Default Engine will not run without choke (Subaru E10)

    Hello,

    My name is Pim and I'm from The Netherlands. We bought an E12 minivan with an E10 engine, but we can't get it running smooth. This is the problem:

    The engine can start with the choke on, but when we switch the choke off after a while, the engine stops running. With the carb on choke, the engine runs fine.

    This is what we did already:

    - cleaned the carb
    - cleaned air filter
    - cleaned fuel tank, lines, pump etc.
    - there is fuel in the float bowl al the time
    - cleaned, adjusted and checked ignition
    - looked for air leaks (false air)

    On the carb we found an electrical choke or something like that. (see attachment, red arrow). We think that is our problem. On this solenoid there is 12V al the time. When we remove the pin inside the solenoid, the engine can idle without the choke but do not respond on the throttle. With the choke on, everything works fine again.

    What is this solenoid and why is there 12V al the time?

    I hope someone can help us out here.


  2. #2
    Join Date
    Nov 2007
    Location
    Spring Hill, TN
    Posts
    2,557
    Rep Power
    9

    Default

    Sounds like its starving for fuel. I would check and recheck the carb and make sure all the jets are clean. don't know about that solenoid. good luck!

  3. #3
    Join Date
    Jun 2009
    Location
    north of Toronto
    Posts
    3,807
    Rep Power
    9

    Default

    the solenoid is the fuel cut off solenoid...it allows fuel to flow to the carb only when the ignition is on
    “The man who does not read has no advantage over the man who cannot read.”
    ― Mark Twain

  4. #4
    Join Date
    May 2012
    Location
    London, Uk
    Posts
    22
    Rep Power
    0

    Default

    hi did you manage to sort out your carb issue? i have a subaru sumo E10 with the same problem. any advise would be appreciated
    thanks
    Paul

  5. #5
    Join Date
    Aug 2011
    Posts
    77
    Rep Power
    4

    Default

    Mine does pretty much the same. Single barrel Hitachi, automatic choke.
    When cold, the engine will simply die off if I don't hold my foot on the gas. The engineer who took a look at it said that it's missing a spring somewhere close to the choke plate. Also, my vacuum lines are kind of messed up. I'm not sure, I will look into it.

  6. #6
    Join Date
    May 2012
    Location
    London, Uk
    Posts
    22
    Rep Power
    0

    Default

    hi, i managed to solve my carb issue (although im not exactly sure what solved it!). looking at your pic the insulation on the solenoid cable come away from the wire. mine was the same. so i cut it off and resoldered a good joint to the solenoid. also make sure you plug it into the wiring loom correctly. on mine the pin inside the white plug was offset, so you have to make sure you have it the right way round when you push it together to make sure it connects correctly. as mentioned above, the solenoid blocks the flow of fuel, until you turn the ignition on. then the current goes to the solenoid which magnetically draws the pin back, unblocking the flow. turn of the ignition and the spring pushes the pin back in place (blocking the flow). if that doesnt work i would recommend cleaning the carb again. i did a thorough job the first time, but sprayed it through with carb cleaner again and an airline,. put it all back together and it worked first time. let us know how you get on

  7. #7
    Join Date
    Jun 2012
    Posts
    1
    Rep Power
    0

    Default

    Hi, had the same problem with my E10. After I changed the sparkplugs it dissapeard but after a couple of weeks it came back. Now the engine is also shokking when my gas half way open, when he is totally open it stops again. You get used to it but im wander if it does damage in the longterm.

  8. #8
    Join Date
    Aug 2010
    Posts
    23
    Rep Power
    0

    Default

    Hi Pim,
    if you give me your email, I can send you some more information.
    Regards
    KleinerMuck

Similar Threads

  1. Replies: 7
    Last Post: 06-07-2012, 04:35 AM
  2. Subaru Sambar Problems with Choke
    By JMR in forum Subaru Sambar
    Replies: 1
    Last Post: 10-03-2011, 05:34 AM
  3. Subaru 2 Cyl engine rebuild kit
    By MiniBrutes in forum Parts Sales
    Replies: 0
    Last Post: 05-07-2009, 05:55 PM
  4. Subaru S/C ECM (Engine Computer)
    By MiniBrutes in forum Parts Sales
    Replies: 0
    Last Post: 03-14-2009, 02:35 PM
  5. Subaru Sambar Engine
    By eeric in forum Parts Sales
    Replies: 3
    Last Post: 11-08-2008, 10:12 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •