Click to view all our sponsors
Results 1 to 5 of 5

Thread: 3G83 runs rough and smokes blue need help troubleshooting

  1. #1
    Join Date
    Mar 2012
    Posts
    3
    Rep Power
    0

    Default 3G83 runs rough and smokes blue need help troubleshooting

    Hello all,

    I recently got a Mitsubishi mini cab pickup with the 3g83 engine. I need some help troubleshooting my problem. When I crank it up first thing, it runs rough and smokes blue, so I know some oil is being burned somewhere. The guy i bought it from said compression tested good on all 3 cylinders, but I have not verified this for myself. Providing the compression checks out, where then should I start with troubleshooting problems on this engine? I don't mind buying tools and equipment but I just hate to start throwing money at the problem trying to fix it. Anybody got any recommendations and procedures for rough running and blue smoke?

  2. #2
    Join Date
    Nov 2007
    Location
    austin,tx
    Posts
    1,718
    Rep Power
    8

    Default

    Compression would be the first thing to check. My factory S81(550cc) Daihatsu service book states 213 psi @ 300rpm and 171psi @ 300rpm min. per cylinder with max. of 14psi difference between cylinders. These #'s will give you a ideal of where you are at.
    As for the rough idle could be a simple vacuum leak, junk in carb, carb. adjustments or coming from the the smoking issue.
    Smoke could be crank case ventilation restriction, pistons, rings, valves, valve seals.
    Mitsubishi are good little trucks but over the yrs. Ive seen more blue smoke coming from the Mits. than any other truck. Seems to me that in the 80000kms +- area the valves are getting weak on Mits. Thats my own opinion. I know several guys that have Mits. with well over 70000kms and the trucks are still running fine.

  3. #3
    Join Date
    Mar 2012
    Posts
    3
    Rep Power
    0

    Default

    Just an update on the situation. I got the truck in my shop to work on it. First thing I found is the oil level was critically low...almost didn't even show up on the dipstick. I refilled the oil level and then opened up the radiator cap. The radiator was empty, but when i smelled inside the radiator, it smelled like engine exhaust. I opened up the overflow reservoir for the engine coolant and it was milky white, so I got a feeling its something bad like head gasket or cracked head/block. It smokes blue out the tailpipe and its ALOT of smoke.

    Where should I go from here?

  4. #4
    Join Date
    Feb 2012
    Location
    Lower Mainland BC Canada
    Posts
    19
    Rep Power
    0

    Default

    Get yourself a cooling system testing kit.

    You can use it to find out if you have a head gasket leak or other related issues.

    A good cooling system test kit comes with instructions to help you pin point cooling system issues, such as head gasket leaks.

  5. #5
    Join Date
    Aug 2007
    Location
    British Columbia Canada
    Posts
    305
    Rep Power
    8

    Default

    We stock piston rings and all the bearings and gaskets for the mitsubishi minicab with the 3G83 engine
    http://www.minitruck.ca
    email westshoreauto@shaw.ca
    Minitruck Parts shipped Nation Wide

Similar Threads

  1. 3g83 rough running
    By Alwardscustoms in forum Mitsubishi Minicab
    Replies: 11
    Last Post: 03-10-2012, 01:21 AM
  2. ecvt troubleshooting
    By gazzz in forum Subaru Sambar
    Replies: 2
    Last Post: 12-18-2009, 07:56 PM
  3. Smokes at idle?
    By JFoshee in forum Suzuki Carry
    Replies: 6
    Last Post: 05-22-2008, 04:02 AM
  4. runs rough
    By badfuffy in forum Introductions
    Replies: 4
    Last Post: 01-06-2008, 07:26 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •