Click to view all our sponsors
Results 1 to 10 of 10

Thread: Stalling Problem on Electronic Ignition

  1. #1
    Join Date
    Apr 2009
    Location
    Wainwright Alberta
    Posts
    5
    Rep Power
    0

    Question Stalling Problem on Electronic Ignition

    Hi!

    I have a 1991 Subaru Van MPFI Supercharger, that I have just bought
    about a month ago. Ive driven it around town and one long trip and had just one problem. It will not sit and idle for long, if you start it let it sit it will
    stop after about 5 min. If you start it and drive it it will run okay until you
    come to a light some times it will be okay sometimes it will stall.

    In most cases when it stalls it wont start up again until it sits for 15 min.
    Ive checked it and have found that it is the spark that Quits and not a fuel
    problem. It has an Electronic ignition. could it be the coil? Why doesnt
    it quit at high speed, just at idle.

    you guys are great I know you can help!

  2. #2
    Join Date
    Jun 2009
    Location
    north of Toronto
    Posts
    3,808
    Rep Power
    9

    Default

    could be a problem with one or more of the plug wires,cap,rotor,or plugs themselves..revving makes it seem smoother because it's firing more often...idle air bypass could be clogged or inoperative..vacuum leak possible
    “The man who does not read has no advantage over the man who cannot read.”
    ― Mark Twain

  3. #3
    Join Date
    Mar 2008
    Location
    winnipeg manitoba canada
    Posts
    746
    Rep Power
    7

    Default

    change the coil. coils will do that when they are bad.
    Please Check out my Youtube Page. subscribers are always welcome
    youtube.com/starpuss

  4. #4
    Join Date
    Apr 2008
    Location
    Yokohama, Japan
    Posts
    368
    Rep Power
    7

    Default

    It either the coil as mentioned above or the pickup module in the distributor. Here is the English parts catalog for Subaru EN07 engines including Supercharged. Also great for you guys with the rare LPG engines.

    http://www.lulu.com/product/paperbac...atalog/5626971
    Cheers,
    Don

  5. #5
    Join Date
    Apr 2009
    Location
    Wainwright Alberta
    Posts
    5
    Rep Power
    0

    Default

    To add info to my post. I am sure that it is an electrical problem because
    I can reproduce it every time at will. I just start it up and let it idle and after
    5 min it will stall BUT will not start again until it sits for 15 min. The I'm sure its
    electrical comes from the fact that when I'm doing this stall test, Ive hooked up
    an old strobe timing light that works off the spark only, and after it stalls the
    spark is gone as shown by the strobe. On tuesday I will be changing the cap
    and wires the plugs look great. Im not sure about where to get a coil or pickup.

    Thanks for the info on the parts book, that will be a big help.

    John

  6. #6
    Join Date
    Mar 2008
    Location
    winnipeg manitoba canada
    Posts
    746
    Rep Power
    7

    Default

    if i am right if your pickup is bad it will not run at all. i say try a coil first
    Please Check out my Youtube Page. subscribers are always welcome
    youtube.com/starpuss

  7. #7
    Join Date
    Apr 2008
    Location
    Yokohama, Japan
    Posts
    368
    Rep Power
    7

    Default

    Due to the high RPM's these engine spin at coils go bad on average 80,000 to 120,000 kilometers. Pickup units get extremly hot in Subaru's due to the lack of air cooling in the rear engine compartment. Yes, I would change the coil out first but nothing worse than finding out thats not the only problem and then having to wait on ordering more parts. Heat takes it toll on electronics. We have the coils used for $65 and distributors rebuilt for supercharged engines at $135.

    Cheers,
    Don

  8. #8
    Join Date
    Mar 2008
    Location
    winnipeg manitoba canada
    Posts
    746
    Rep Power
    7

    Default

    Go to your local auto junk yard and pay the 5-10 bucks they would want for a used coil and give it a try. Is your coil a 2 wire?> if so most coils from all cars will work on yours.
    Please Check out my Youtube Page. subscribers are always welcome
    youtube.com/starpuss

  9. #9
    Join Date
    Apr 2009
    Location
    Wainwright Alberta
    Posts
    5
    Rep Power
    0

    Default

    Thats just what I did, I got an old coil from the local yard, hooked it up and POOF
    the stalling problem is gone. Just in time cause winter is gonna come any day now
    and I need my Subaru for work.

    Thanks! everyone for all your help, it was much appreciated.

    Johnwscooking

  10. #10
    Join Date
    Dec 2008
    Location
    Cebu City, Philippines
    Posts
    11
    Rep Power
    0

    Default

    same symptom as mine the only difference is that i have my engine light come on. took us awhile to diagnose the camshaft sensor problem. when the sensor gets hot... it sends the wrong signal to the PCM/ECU making the engine out of timing, thus shutting it off.

Similar Threads

  1. ignition switch problem
    By 0neshot in forum Suzuki Carry
    Replies: 4
    Last Post: 04-20-2012, 10:45 AM
  2. New to site - problem ignition coil?
    By boggy in forum Subaru Sambar
    Replies: 3
    Last Post: 06-30-2010, 03:51 PM
  3. electronic speed limiter?
    By do it best 4x4 in forum General Truck Info
    Replies: 4
    Last Post: 11-10-2009, 09:49 PM
  4. Points or Electronic Ignition
    By Rickyb in forum Suzuki Carry
    Replies: 4
    Last Post: 12-06-2008, 09:06 PM
  5. 92 Carry Stalling Problem
    By rshier in forum Suzuki Carry
    Replies: 21
    Last Post: 04-03-2008, 06:44 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •